Custom subdomains not linking

Problem description: My custom subdomains are not linking after 2 or more days. I have been using 내도메인.한국 for my subdomain provider and it worked 2 times before and now it doesn’t work. (NOTE: The provider doesn’t allow CNAMEs and TXT records to be added together.)


Expected behavior: After following instructions, the custom domain should work after 48 hours.

Actual behavior: After following instructions, it’s stuck on the linking process after 48 hours and only shows this error when visiting the custom domain: “Run this Repl to see the results here.”

Browser/OS/Device: Browser

Hey @sxh welcome to the forums!

This is a known problem that the staff are currently trying to fix. Please be patient while the fix it. Hope you have a good day :grinning:!

1 Like

Custom domains worked fine for me today when using CloudFlare. Maybe try using CloudFlare as your DNS service (it’s free and you can link with your existing domain!). Replit also recommended it on their post talking about this issue.

Pretty sure cloudflare doesn’t accept subdomains. Tried it a while ago. Thanks for the suggestion, though! The thought counts. :slight_smile:

Since when? You can assign whole nameservers (NS record) to your subdomains, why wouldn’t you be able to assign a CNAME, A, or TXT record to it?

And is a subdomain, not really a domain. (like

You need to set nameservers to cloudflare and then you can do subdomains in cloudflare

I have linked to a repl

The problem still exists even when says its okay.

I have 2 repls still not linking. Did I hit the limit or something?

Please refer to our official response on this issue here:

Please let me know if you are still having issues after reading the response above


So it’s like a security measure to see if the domain is really mine or not. I understand but my last question is why did it work before? I did this before with FreeDNS, x10Hosting, and InfinityFree.

1 Like

We believe that some DNS services have recently started adding an A record alongside a CNAME record even if a user only explicitly adds a CNAME record for their subdomain. This prevents our system from properly verifying the domain, especially if the DNS service blocks TXT records on the same subdomain as another record.