Custom domain name not showing properly

Question: May someone show me an example of GoDaddy registrar settings for a custom DNS. I have failed to get it correct.

It routes only the top-level but shows the repl URL rather than my custom domain.

Replit Profile: https://replit.com/@Nomon

1 Like

I use Cloudflare for all my domains but godaddy will be the same. For replit you need a CNAME dns rule. The name should be your url, and then content will be the CNAME content that replit gives you to copy.

For example, mine is:
CNAME rickroll.theflamongo.com********-****-4e61-8bf0-3e111ec7a2f8.id.repl.co

You will alslo need to add a TXT dns rule to verify the domain. Mine is:
TXT rickroll.theflamongo.comreplit-verify=********-****-4e61-8bf0-3e111ec7a2f8

2 Likes

I actually have the same issue. Added a CNAME and verified via TXT and when I to to blog.csteach.uk the main page works but any other links display the repl URL as @Nomon mentioned.

After clicking on the blog title:

1 Like

What are your anchors pointing to? If they are pointing to /about then it shouldn’t change the domain, but if they are pointing to something like yourdomain.com/about and that domain isn’t the linked domain it will change it. That’s the only thing I could think of being wrong

1 Like

It’s a wordpress install so they should be relative links.

1 Like

If I use inspect they aren’t. And if I change the link to just /about then it works and keeps the domain the same.

1 Like

Weird. But those page links are created by the Wordpress install, so I’ll look further. Thanks!

2 Likes

if I remember correctly, wordpress has a setting for the url for anchors, I think you have to change that. Could be wrong though, I haven’t used wordpress for a bid.

2 Likes

That’s a great shout. Thank you @InvisibleOne . I’ll take a closer look at the settings maze!

I think it’s in the config.php file as this setting is greyed out. Getting closer to solving this!

2 Likes

@InvisibleOne 's suggestion for Cloudflare was sterling (good no-nonsense interface). It conformed to the Replit instructions perfectly. I am going to avoid Godaddy in the future.

3 Likes

Thanks @InvisibleOne when I edited the Wordpress config file it worked perfectly.

2 Likes