Custom domain linked, but not working (SSL ERROR)

I have a domain name,, which is linked to GitHub pages.

I’m trying to link a subdomain,, to my Repl. I followed the tutorial as best as I could.

I was able to verify the subdomain, as you can see in this screenshot:


However, when I try to open that URL in a browser, I get the following error: SSL_ERROR_INTERNAL_ERROR_ALERT, as seen in this screenshot

This is despite the fact that the DNS linking has worked (

Can anyone help?

How long ago? The linking can take up to 3 days sometimes, depending on many factors.

@ShaneAtReplit if I missed something.


Btw, oops! The popup you see in the last screenshot of the DNS website is actually unrelated to the query haha. (It’s a browser extension I built for myself to keep me from going down internet rabbit holes…)

Hey. The linking already seems to work as I show in the screenshot. What is the SSL error for?

I am facing the exact same issue. I have linked my domain and am getting the SSL Error for some reason. I have not faced this issue before when linking my sub domain in the past.

It looks like you are missing the TXT record on the custom domain. If you add that, that should allow the domain linking process to move forward


Hey Shane — apparently on GoDaddy, you can’t add both a CNAME and a TXT record for the same target (it violates the rules). Am I missing something, or is there any workaround?

Oh no! I’m not sure if we have a workaround, I’ll ask the team!

1 Like

is this fixed i cant access custom domain through https. my custom domain is linked but there is a ssl error while accessing.

1 Like

Welcome to Replit Ask! Try waiting a few hours, it might just take a while.

thank you. i will wait.

1 Like

I’m sorry for the wait! I’ve prompted the team for an update on the issue and will follow up once I get a reply!

Can you send me the link to your Repl and the domain you’re trying to link to?

Sure Shane. My repl is

And the custom domain is

I’m having the same issue when deploying to a custom domain. Tried both the TXT and CNAME records (you cannot do both at the same time).

If I use CNAME it is just perpetually in “verifying”, even after 48 hours. I’ve never seen a custom domain take this long to propagate before.
If I use TXT it verifies quickly but I get a DNS_PROBE_FINISHED_NXDOMAIN error when actually trying to load.

having same issue:

My repl is

And the custom domain is

For those of you affected by this issue, can you please make sure you sent your Repl and domain somewhere in the post?

Also, if you are using a CNAME record, try using an A + TXT record instead which might fix the issue.


any update on this? i am using CNAME and TXT both

and still there is error.

1 Like

No update yet. We are still investigating this issue and have not found the cause.

Also experiencing this issue, will post my repl and site here:
repl (Cover page):
repl (Site):
Custom domain: