CSS To My Replit Isn't Working

I’ve redesigned my website on my phone. I coded and tested it with Acode and everything works as intended. I compressed the project as a zip file and uploaded it to replit replacing the old index.html file with the new one. I used the shell to unzip the project using the unzip site.zip command. However, when I run my replit project the css isn’t loading.

Therefore to further debug. I went to view-source:my-replit-url and clicked on the url of the files that the project requires such as the css, javascript, images and video. Which I discovered that none of the files that were uploaded are found. This confuses me because it shows the files in the menu. So I went to the shell using the ls command and my files are there.
Which begs the question. Why is my replit project not finding the files that I’ve uploaded which show up in the shell and worked perfect locally on my device?

Here’s a link to my repl

I found a partial stupid hacky fiz where I duplicate the file (say style.css), delete the old style.css, rename the duplicated style.css (copy) to style.css. which solves it for just that file.

There’s no way I’m doing this manually for every file.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.