Creating repl error message

Expected vs Current Behavior:
Error “There was an error connecting to the server”

Steps to reproduce:

Bug appears at this link: https://replit.com/@gmf2022-tech/CaringLooseArchives

Replit Profile: https://replit.com/@gmf2022-tech

What is the external IP addresses that running the repl script goes to so we can add those to our firewall. We presently have a number of school using this service.

Hi @gmf2022-tech , welcome to the forums!
Try unblocking the *.replit.dev domain, as that is the domain controlling the Output.
Hope this helps!

That did not work.

So far on our firewall we have added the following

www.replit.com

replit.com

replit.dev

It has to be *.replit.dev, not just replit.dev

2 Likes

@gmf2022-tech The * is a wildcard domain, so anything that ends with replit.dev will be unblocked.

2 Likes

yes, added *.replit.dev and replit.dev and still without success

1 Like

Hang on, could you try moving Main.java out of the folders?

So, I am not a dev person. I part of the security team at our school board that manages firewall access for websites. Many of our educators and students use replit as a learning tool. How do I move it?

thank you for the support.

Just click where it says Main.java in the sidebar, and drag it above the src folder.

1 Like

same error when I run it.

@gmf2022-tech Can you close/exit the output window and run it again? Or try forking it? If you’ve allowlisted all the Replit domains, it might still error because the previous result is cached/stuck in the error. I’d also recommend testing with a fresh browser cache or another browser.

3 Likes