Could not parse version constraint: latest exit status 1 when removing packages

Issue: When I attempt to remove packages from the packages tab I get the error in the console:

Screenshot 2023-12-31 at 2.08.16 PM
Screenshot 2023-12-31 at 2.08.02 PM

Repl link/Link to where the bug appears: https://replit.com/@AkshatPrakash1/Discord-Bot-V2

Hello,
it looks like there is an error in your pyproject.toml file.

Under [tool.poetry.dependencies],

yt-dlp = "latest"

This is incorrect. You should change the value to something like "^2023.12.30", or if that doesn’t work, then "*" .
Then, type poetry update in the shell, and that should fix any problems.

2 Likes

Doing that resulted in this error.


However when I changed python to “>=3.8.0,<4.0” I got this error

Hmm, could you take a look at your pyproject.toml file, at pseudo-microbit?
It seems to me that this is not a package that you are using, and uninstalling it should fix the error.

Screenshot 2023-12-31 at 4.32.55 PM
For some reason it says it is not install even though I see it in the toml.

Screenshot 2023-12-31 at 4.33.38 PM

Try poetry remove pseudo-microbit instead.
If that doesn’t work, remove the line from pyproject.toml, then poetry update.

1 Like

It down graded many of my packages but I still have an error.

Now each time I run the reply I get this.

I forked your repl and was able to get the packages working with the following steps:

Open pyproject.toml, and remove the line:

pseudo-microbit = "^1.10"

on line 18.

Type poetry update in the Shell. And wait for a while. That fixed the package issues on my fork.

1 Like

Thank you so much, that fixed it.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.