Console keeps running endlessly without any output

Question:
This has been happening in the last few days. I test my code by pressing Run and it runs endlessly. And, no, this is NOT because there is an endless loop in my code. I´ve tried running code that worked and it has the same problem. It just says “Working” and nothing happens.

Repl link/Link to where the bug appears:
https://replit.com/@mmgrillo/day23100-days#main.py

Screenshots, links, or other helpful context:

code snippet

Seems to work on my end, I’m not sure.

EDIT: it seems to be stuck on working… and your code’s fine, so it seems to be a fault on replit’s side (it seems to be due to it being a 100 days tutorial)

1 Like

Seems to work and i do not see why it should not looking at the code.

1 Like

Now I know why so many people give up on the 100 days tutorial :slight_smile: Thanks for checking!

Thank you for checking!

It may actually be due to the exit(). You should refrain from using it because it causes a SIGABRT meaning the console isn’t able to load in the 100 days repl as well as having no real use (it’s mainly used in low level languages).

Hi @mmgrillo , welcome to the forums!
Can you try entering kill 1 in the Shell and see if that helps?
Hope this helps!

3 Likes

I´m going to try this! It might have started when I started using it. I used to insert it because it forced the console to stop (and this way I wouldn´t need to press the stop button on top after the code runs). Thanks for your help!

I´ll try that when/if it happens again! I´ll let you know! Thanks!

1 Like