Console doesn't show sometimes

Problem description:
Pressing the “Toggle Developer Tools” button doesn’t show the developer tools.

Expected behavior:
The developer tools would show.

Actual behavior:
Developer tools doesn’t show

Steps to reproduce:
It happens sporadically in some of my classes to my students.

Bug appears at this link:


It’s tough to give information on these bugs because each day it can work or not work. For the console to show up for one student, they had to type some text, delete that text, and then press the Developer Tools button inside of and then it would show up. That only worked for two students. The next day they didn’t need to do that.

Another student restarted their Chromebook and it fixed the issue, the same did not work for other students.

One student has not been able to open the Developer Tools, maybe ever. He reported this issue and the next day he was unable to login. Then the next day he was able to login again but the developer tools still didn’t work.


Hey @DavidHust1!

Are you able to open up the browser’s devtools and send us a screenshot of the errors, or is the Chromebook locked down?

Can you try using If this is a network issue, using firewalledreplit will hopefully eliminate it.

It’s locked down :frowning: The dev tools in are our only hope.

I apologize for the delay! Did you try, and did that work?

1 Like


The main issue now is that he isn’t able to sign in to his account. He tried clicking on “forgot password” but it states that his email doesn’t exist. Thoughts on how to proceed?


What is the username of the student who can’t sign in? (you can message this to me privately)

1 Like

Sure I can upload what seems to be an issue. I am using ubuntu 22.04 and it is not working at all I click on the wrench and it doesn’t show up. I am doing the odin project /enter-a-number#script.js all I can do is run inspect and run in console in the actual chrome browser and that is where the error code is coming from. There is no full page that shows the black console, I was speaking with someone working
from an Apple and it was working just fine. So is this a linux issue? This is not on occasion it is constant.

I just helped someone with a similar problem. They were in incognito mode in chrome, and the fix was to use the site without incognito mode. After that the “Toggle developer tools” button started working again.

1 Like

Thanks but that is not it. :slight_smile: It is ok I just use a work around, I open the following page next to toggle and use google inspect and google console. If you see the screen shot, if it was in incog mode you would see the writing on the top right corner as well.

1 Like

The best way around it is to use googles dev tools and not worry about using the websites, it is just quicker to do it this way it seems like there is a real fight to use the tools on this website. I am sure at some point it will be fixed and it doesn’t take away from the experience I think there should be a written warning though over the tools in red saying if they don’t work to use google’s dev tools instead.