Code ruined by AI + autocomplete

Problem description:
My 4 hours of work literally got changed and ruined by the replit autocomplete

the problem is not that it is changed, I can easily restore it but the problem is that I need to do it so often

do I need to explain more

Restore your code using File History.
is there anything we need to know about the “Steps to reproduce” (which is a template field given when you create the post)?

Hi @solidracer !
Could you just press CTRL+Z to undo?
Also, please avoid using profanities here.

Steps to reproduce is writing a code for 10 minutes and it just happens and replaces everything

What about using History or undo?

I can only use history bcuz the autocomplete or the syntax highlighting changes the code and thats not the problem the problem is that I need to do this very often and its annoying

Are you saying that the grey-ish code pops up while you’re typing?

Also please send a Repl Link or a screenshot, otherwise we have little to no idea on what the problem looks like.


To disable AI autocomplete, click the AI button near the bottom of the file and uncheck the Autocomplete checkbox. Or, in the replit editor, open Settings (through Tools or in a New Tab), and turn off AI Code Completion.
Both of these will disable AI autocomplete for all of your repls.