Code not working anymore

I have code from before the newest release in the update and it worked just fine like it was supposed to now it runs for 2 seconds and gives me a bunch of error text and things that don’t make sense

Hello @KadenGerulski , welcome to the forums!

Could you send a code snippet and/or a link to your project? Thanks!

here is the link do u want edit acces?

i sent you a invite to edit

Don’t need an invite link, but I found the problem - as of a recent turtle update, turtle.color’s rgb system uses a 0-1 scale instead of 0-255 scale - so change it to something like + (1/255) or some other small decimal value.

can you explain it in a dumer way?

AquiIo what you said made no sense I tried to reread it multiple times and tried to get wride of the 0’s and replaced them with a 1 and got wride of the decimals and still didn’t work

Take anywhere you mess with the r, g, and b, and divide it by 255. (Unless it’s 0, then you don’t need to)

ok? thanks for the help ill try and see if it works

1 Like

are you sure that’s correct the number I got was ridickisly small

It would be, yeah. Actually, you can just change one line:




that the only change I need not the really small number?

From looking at your code, yeah, that should be it.

1 Like

that works thanks a lot for dumbing that down that code is over a year old so that means a lot to me for that help thanks to both of you

so once the code finished it showed another error do I need to fix that or no?

Could you provide the error message please?

copy and past is what your asking right

That would be sufficient, yes. Preferably, format it like this:

Your error message here

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.