Code intelligence won't turn off in python poetry

I am using poetry in my python project, and I disabled code intelligence, but it still works and makes many spaces around dash(-) in modules when I press Ctrl + S to save the file.

How can I save the pyproject.toml without any spaces?

In replit you don’t need ctrl+s to save. It auto-saves (I think)


Like dragonhunter1 said, don’t use Ctrl+S. It auto-formats everything. Replit still saves stuff without that (you can always run the Repl to double-check). I had to stop using Ctrl+S to make this.


Hey there! Welcome to the community! You can disable code intelligence by going to settings in the tools and scrolling down to code intelligence.


I tried that before and it didn’t work. Since you suggested it, I tried it again. You have to refresh the page for that to work. Also, it only applies to the Repl you change the setting on, which is nice.

1 Like

Oh, sorry for that, I thought it works.

Sorry if I worded it wrong. Your idea works; you just have to refresh the page again. In the past, I had tried that and NOT refreshed the page, and it didn’t work. You putting that answer there made me try it again and I discovered that refreshing the page applies the change in settings. You were right and I didn’t mean to make it seem as if you were wrong.

So it works now? If so, could you mark this as complete?

@CoderElijah wasn’t the one with the problem, it was @azvast xD

Also I think @dragonhunter1’s solution was the only actual solution for the OP, @azvast probably got confused with code intelligence