Code Intelligence doesn't work in C# Repls

Bug description:
When typing code in a C# repl, only syntax highlighting works properly. Autocomplete and hints do not work at all.

Expected vs Current Behavior:
I expect it to have autocomplete, syntax highlighting, and hints working, but only syntax highlighting works.

Steps to reproduce:
Open/Create a C# Repl and start writing code is a .cs file.

Bug appears at this link:
Any C# Repl (dotnet, not Mono), so I don’t know what link to put specifically

Screenshot(s)/Screen Recording:
Here is a video showing code intelligence on, but no hints showing up, and no functions or properties showing up in autocomplete.

Browser/OS/Device: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/116.0

Replit Profile:

:wave: Hey @KingOworld, welcome to the community!

Did it work before? Have you tried refreshing after toggling Code Intelligence?

It has worked before, and yes, I have tried refreshing code intelligence many times and even tried making a new C# repl to see if the problem persisted. My friend has been having the same issue as well.

No, refreshing your browser.
If that doesn’t work, Replit likely doesn’t have support for C# code intelligence.

I have done that many times, it used to work, now it just randomly doesn’t.
If it used to have support and now it stopped working, would I just have to wait for support be implemented again?

Maby create a new C# project and check if it works. Or look for an older C# project (where it did work) and see if it still works.