Code disappearing when I type

Problem description:
When I type code, the cursor stays in the same place, the text appears

Expected behavior:
When I type, the code should stay and automatic saving should be activated.

Actual behavior:
When I type code, the cursor stays in the same place, the text appears, then after 1-2secs, the code I just typed disappears. When I copy and paste in code, this seems to activate an automatic save, but when I start typing again, the cursor stays in the same place and doesn’t activate save.

Steps to reproduce:
Start typing. It’s inconsistent

Bug appears at this link:

Browser/ Laptop

I experience this only in one case, apple laptop and safari … the IDE goes mad after few minutes with enter adding lines but cursor stays there, tabs changing panes, text vanishing, etc.


It it just a temporary thing? It’s absolutely maddening! Got a 3hr block to do some work and couldn’t predictably type anything for the whole period.

I’m on a new Microsoft Surface 5 Pro

Switched machines, network and location and the problem persists. Does anyone have any idea why this could be happening?

Hey @soze316 welcome to the forums!

I have run into a problem of when I type the words vanish. I had accidentally typed a combination of keys on my keyboard. I looked up how to fix it and it worked. If I were you I would try this to see if that fixes it, if not try asking someone you know that is good with computers to see if they can figure it out. I hope this helps you! Have a great day :grinning: !

Well, i ditches mac os and put ubuntu on my old mac ans that solved my problem … but if this happens on a surface is really weird.

I thought it might be something like that initially (re. key combinations), but the problem resolved itself after 30mins, or whenever I pasted a piece of code in then continued typing. I then went to a different machine completely and the problem as still there.

I’ve been using Replit for years, so hopefully I’m still not a newbie. Never had any problems I couldn’t resolve with some effort, except this, which I appear to have no control over. :smiling_face_with_tear:

I’m still experiencing the same problem. It doesn’t matter which device I use. I’ve added a screen recording which should hopefully explain the situation better.

Recording 2023-05-04 114908

1 Like

This is really strange. Replit staff should be pinged.

1 Like

How do I ping the staff?

I am experiencing the same problem as Soze316.

Hey @soze316!

What Browser + OS are you using? Can you send me the names/versions of both?

I am experiencing this on chrome 113.0.5672.64 / Windows 11

I am only getting it in one file all the other files work fine.

1 Like

That’s very strange. Can you send me the link to your Repl and let me know which file this is happening for?

I’m not the original poster, but if it helps:

Chrome - Version 112.0.5615.138 (Official Build) (64-bit)
Windows 11 Home - 22H2

1 Like

Windows 11 Pro 22H2 22621.1555
Chrome Version 112.0.5615.138 (Official Build) (64-bit)

@harpoRich @soze316 Can you try using Replit on a different browser or temporarily disabling all of your extensions to see if that fixes the issue?

1 Like

Hi Shane, I’ve just tried it on Firefox 113.0 (64-bit). So far it works. However, when I tried it with an earlier version of firefox 111.0 the error returned after a short while.