Chromedriver nix pkgs update

So I installed chromedriver using nix environment but the version is 108 but I think I need 112-114 for the latest chrome (so how do i specify the 114 version?).

When I tried downloading chromedriver.exe and using selenium, I get exit code and couldnt figure out so i think maybe the above might fix it: selenium.common.exceptions.WebDriverException: Message: Service /home/runner/.cache/selenium/chromedriver/linux64/113.0.5672.63/chromedriver unexpectedly exited. Status code was: 127

Hi @RikeshPatel3 can you share a link to your Repl please?

Thanks. I focused on resolving your error message rather than the chrome version.

You can’t run chromedriver.exe in a Repl because it is a Linux container. I noticed you had also downloaded chromedriver which I suspect is the Linux version. I replaced it with a freshly downloaded copy to see if this altered the error message. It did but wouldn’t run chromedriver as it needed to be in the PATH.

At this point I looked at some other Repls where chromedriver is mentioned or used.

https://replit.com/@TheHackerDude1083/Selenium?v=1 - this works really well!

https://replit.com/@ShopCommends/chromedriver-open?v=1 - a more complex Selenium install

Would forking either of the above Repls help you achieve what you want to do here?

1 Like

Hi Ian, thank you very much, your solution for selenium worked perfectly.
I am hoping you can guide me in the right direction again. Thank you in advance.
One last thing I need is the python ‘pandas’ package. Adding to nix did not work for me
and I cannot install pip for some reason. This is that repl: https://replit.com/@RikeshPatel3/Selenium-2#main.py

I also tried to use the selenium repl in a python repl with its files but gave me this error: /nix/store/hpbvrlwd5viqmvcaisb3x0118i913a9n-stderred-0.1.0/bin/stderred: /nix/store/s9qbqh7gzacs7h68b2jfmn9l6q4jwfjz-glibc-2.33-59/lib/libc.so.6: version `GLIBC_2.34’ not found (required by /nix/store/mdck89nsfisflwjv6xv8ydj7dj0sj2pn-gcc-11.3.0-lib/lib/libgcc_s.so.1)
repl process died unexpectedly: exit status 1

Hi @RikeshPatel3 glad it worked for you.

To install the pandas package please use the Packages icon on the left hand side of the Replit UI

I’m sorry but I don’t understand what you are trying to do with regard to your second question. Do you mean you are trying to have one Repl link to the code in another Repl?

1 Like

Yes I did that already and maybe you can see that pandas 2.0.1 is installed. However when I try to import pandas in python, it outputs error: “No module named ‘pandas’”. Do you see differently?

The second part of my question was an attempt at downloading pip with pandas if that was another possible solution, but the selenium installation arose again as an issue. The method was creating a new Python replit and moving the files from the Selenium replit to the Python one that would hopefully have pip installed so i could download pandas.

Thank you!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.