Certificate not valid

Question:
Repl was working fine and then all of a sudden cert becomes invalid. Why does this happen and how do I resolve it?

Repl link/Link to where the bug appears:
https://qlik-embed-oauth-spa.qlik.repl.co/

Screenshots, links, or other helpful context:

code snippet

Hey @goldbergjeffrey!

The repl.co domain is now being deprecated and will be fully replaced by Deployments by January 1st, 2024. See this post:

You may want to migrate to Deployments.

Ahh ok. That’s fine. Can start using replit.dev domains today? And will replit.dev support pop-out like today in webview? Asking because we’re embedded SaaS and embedding in a window embedded in a window sometimes creates challenges.

@goldbergjeffrey that has nothing to do with this afaik

this is what the site looks like:

image

I dunno why it says cert invalid but maybe that has something to do with it :woman_shrugging:

It stopped and now it’s working again. I think there must have been a dns hiccup on the replit side. I just tried deploying and got the same issue now but with replit.app domain:

I’ve since deleted the deployment so it shouldn’t work. But if I run the repl with this replit.app domain, it did go to my IdP and auth, but then callback url landed here.

Happening again. What’s the best way to get certs reset?