Can't type text into inputs when using Debugger

Bug description:
Im doing the 100 days of code python course, on day 58 I use the debugger the first time. When I set a breakpoint like david in the video, I cannot input any variable or nr. into the console. On top of the console I see the blue loading bar nonstop.
Replit uses about 10%CPU at this point

Expected vs Current Behavior:
I should be able to input variables in the console, which I am not.

Steps to reproduce:
Just do the day 58 of the python course. After setting the breakpoints I cannot input anything to the console.

Bug appears at this link: https://replit.com/@cbrenner/Day58100Days

Screenshot(s)/Screen Recording:

Browser/OS/Device: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/119.0.0.0 Safari/537.36

Replit Profile: https://replit.com/@cbrenner

1 Like

Replit has updated the console, which is why the console cannot be used as a Shell.

I’m not trying to use the shell. I wanna input something to my input() command.

Just recognized problem apears when I run the debugger, no breakpoint needed.

2 Likes

Can’t you type text in this place? Also, could you send a screen recording?

Yeah thats exactly the problem.
When I run the replit itself I am able to do some inputs, when running the debugger I am not able to input anything anymore.

Sadly hard to do a screencapture with max 8MB filesize. But you will not see much anyway as I am not able to input anything.


Tried to compress it, not sure it works as I dont have a video player on my work pc.

I was able to reproduce this bug.
To clarify, the console organizes output into “sessions” so that you can see previous runs. These sessions are labeled either “Run”, “Packager”, or “Debugger”. It seems that only “Run” sessions allow typing into the console, though “Debugger” should too. “Packager” does not need to allow typing into the console.

2 Likes

I’m having the same problem right now too.

doesntwork

Also Interpret for, well, interpreted languages.

I checked this and made sure that the input in Debugger usually does not work. I managed to type once from the keyboard.

how does one access these sessions

It’s just the different dropdowns in the console. Each run has its own dropdown for its output, and the packager and debugger also have dropdowns for their output.

Thanks for reporting this debugger issue with the new console. I’m going to open a ticket internally for the behavior.

I’ll also mention that we have a few sections in 100 Days of Code that could use an update, particular due to the console changes. In general, the courses are still quite good so just being honest it might take some time to update them all alongside new features and changes.

I’ll let you know if I receive an update from the team and hopefully we can workaround until they are able to review it.

2 Likes

Hi All. Can one of you kind folks (@cbrenner @NuclearPasta0 @vvithershins) test and let us know if this is still occurring? I went to reproduce today, but I could type in the debugger without issue. Possibly one of our other improvements also fixed this issue.

Yes I just tested it and it is working, I believe it’s been working fine for a few days now I had just forgotten to mention it. My apologies.

1 Like

Thank you for confirming!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.