Can't run the code


When i run my code, it shows this. I searched on YouTube for the solution but there’s no such tutorial to fix this. Hope this gets fixed ASAP.

Hey @ExploiterSolo, welcome to the forums!

Could you provide a repl link?

Try refreshing. Replit has been going through a lot of changes, and it seems one update always breaks another. If this doesn’t work, wait for ~1-2 hours and try again.

1 Like

Did you check that your main html file is called “index.html”.

If it is, it may be an issue with repl.co websites crashlooping (you can view it here) and may be unable to load files from your repl.

4 Likes

This question was recently asked in #code-help here, where I have answered it. Can we merge the topics and move the question to #code-help, @hugoondev @MattDESTROYER

1 Like

Whats your discord? ill text you there

its been hours, still not working :frowning:

did you check the html file?

edit: i’ve checked your repl. it has a index.html. however, the source for your css and javascript files need to be renamed to their path for your website to work.

Ask @not-ethan if you need something merged. We don’t have the permissions. I think this would be better just marked as duplicate than merged as there’s no new information here

I think its better to move the replies since theres info there that’s not here. And for stuff like this a flag will do since somebody else could get to it before me

It’s because there’s no index.html file in your repl! By default, replit uses index.html as entry point to run the html, css, js template.

If you visit Lusion you’ll notice that this link works fine, because there’s an index.html in that folder. What you’ve attached in image is a 404 page.

To solve this, you can create an index.html or change the entrypoint in .replit file to this link. You can view .replit file by clicking on show hidden files likewise:
Screenshot_20230128-134313_Chrome

The HTML works fine now but the CSS and JS is is not working.

When i get into .replit , where do i paste the link?

The CSS won’t be working because you’ve changed your file structure. You’ve got this link tag:
<link rel="stylesheet" href="assets/css/main.css"> when your CSS is now actually in lusion.co/lusion.co/assets/css/main.css.

1 Like

I TRIED IT! But it just shows white screen now.

move everything out of lusion.co/lusion.co folder. You can hold shift while you click 2 files to select all files between the 2 files.

2 Likes

Hey, your website seems to be working fine; were you sble to solve the issue?

it seems to load correctly; it fades to black now. Is there suppose to be some content?