Can't override [packager.features] > guessImports with Nix Modules enabled

Problem description:
I have a project in which I customize some Typescript import paths to @/components, @/lib, etc. It uses the nodejs-18:v3-20230608-f4cd419 Nix Module.

The Module comes with import guessing on by default, which causes the packager to try and install @/components and @/lib.

Screenshot 2023-10-19 at 6.19.51 AM

When I put the following code into my .replit file to turn packager.features.guessImports off, the packager still makes an attempt to install them via npm.

[packager]
language = "nodejs"

  [packager.features]
  packageSearch = true
  guessImports = false
  enabledForHosting = false

Expected behavior:
The packager should not try to install the path aliases when guessImports is turned off.

Actual behavior:
The packager tries to install the path aliases regardless of guessImports

Steps to reproduce:

  1. Create a new Typescript Repl
  2. Add the "paths": { "@/*": ["./*"] } to tsconfig.json (compilerOptions)
  3. Import something from a path alias somewhere in your code
  4. Packager kicks in when you run the Repl

Bug appears at this link:
Occurs in any Repl with typescript-language-server and the nodejs-18:v3-20230608-f4cd419 Nix Module.
Reproduced in: https://replit.com/@IroncladDev/ShadCN-UI-Boilerplate
Repl ID: 524d787b-e770-4201-a6aa-4c0c20ecb8f7

Browser: Chrome (Reproduced in both desktop app and chrome)
OS: MacOS
Device (Android, iOS, NA leave blank): Macbook Pro 14" Sonoma
Desktop app version (Avatar menu->“Version”) or NA: 1.0.4
Plan (Free, Hacker, Pro Plan): Pro Plan

Hello, this bug was reported long ago and that configuration is now outdated, replaced with a new setting:

.replit file (top-level):

disableGuessImports = true

The docs for configuring a repl are outdated too but this also has been reported.

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.