Can't open replit on PC

**I can’t open replit.Com on my laptop but it works fine on the mobile browser and the mobile app
I need to work on the laptop as replit is used in my python programmer course. And I’m not sure what is the problem which is repeated on another pc I’m using.
*

Hi @MinaEmad1 , welcome to the forums!
Try adding www. before replit.com in your url and see if that works?
Or click here: replit.com

1 Like

Thank you, I have tried adding www. But without any success as you can s
Screenshot_20240226_133302_com.whatsapp.w4b
ee here.

Try using a different browser instead of Edge maybe? Like Chrome or Firefox?

2 Likes

I did that also, but it didn’t work either

Could you try running Invoke-WebRequest https://replit.com in Windows Powershell?

I tried this technique by openning powerhell on my laptop, and running the power rshell script but all it gave was just a message that it is reading data and nothing else, any idea what the next step

Check your wifi. That typically appears when you have blocked/no wifi. For example, my parents can toggle wifi to my computer from an app on there phone.

I tried running the laptop on my phone Hotspot but the problem still the same, I think there a blocking app on the laptop preventing the website like the firewall or the the anti-virus, I tried to search in the blocked websites list but found nothing, are there a way to figure out which app is blocking the website.

Replit’s homepage is on the bare domain, so that wouldn’t work. In fact that’d probably produce that error (well, www just redirects to bare)

image

Okay for me there was a really weird day where almost every website except maybe Google would do this. Try restarting your computer. Otherwise try running ping https://replit.com in command prompt (:window: + R and typing cmd.exe). I think ping is basically the same as

but still worth a shot. Otherwise try disabling your extensions and maybe your antivirus


If that fails, are you able to connect to a different Wi-Fi network? That could very well be the problem (blocking software, or very simply just an outage).

well, i’m not sure if this is the exact answer, but i always open replit as https://replit.com/~ with a ~ at the end

That wouldn’t make a difference in this case, given that it looks like a DNS error.

1 Like

How to know if it’s dns error?

It looks like one to me, seeing as the error code is NXDOMAIN, could you try changing your DNS to something like 1.1.1.1 or 8.8.8.8?

1 Like

Wasn’t it just replit.com that was doing this?

1 Like

@Firepup650

And you can see the other tabs working fine

And that means it isn’t DNS how? Could somehow just be missing (intentionally or not) the DNS records for Replit.

1 Like

So, I think it’s quite a persistent problem onmy laptop, where it may take time to know exactly what is causing this error
As I’m using replit to study python programming course, is there any possible work around suh
As open replit through an intermediate website with different url

Not sure if that would allow Replit to work properly, could you try the solution I suggested first?

1 Like