Can't open a my first repl. Firewall issue?

I’m a teacher at a school. I’m trying to get my students using the Education version so that I can support their Python learning.

I can create repls etc and do everything normally but the students can’t. I’ve tried a student using and Neither work for the student. Both work for me.

This suggests a firewall issue.

However, my IT team have assured me that and are both whitelisted.

I’ve tried looking at the browser debug console to see what resources might still be blocked.

(I can’t upload a post with two or more links so I can’t upload my screen shot.)

Can anyone make any sense of this or suggest why students are blocked and I’m not. Your assistance would be appreciated…

Hi @MrChallice, could you please remove the code formatting from the text and reupload the screenshot, so we can help you further? Thanks.

1 Like

Some kind soul has already edited the post. Does that help?


is * whitelisted as well?


Our IT support guys tell me it is.
Anything else you can think of?

1 Like

maybe the filtering proxy falsely detected something objectionable in the script? :person_shrugging: There must be an option to skip content filtering on, which is in control of replit; it doesn’t include any user-generated content

1 Like

So I have done some more testing using a student account…

Students cannot create a repl but I can.

I’ve looked at the blocked resources. All of them work for students except for this one, which is blocked for students:


If I try to open it as a student I get an error saying Access to {cdn replit com} was denied. You don't have authorization to view this page. HTTP error 403

When I log in to the same network with my windows user id I can open this specific js resource with no issues.

It’s not a general problem with students opening resources at as other resources at CAN be opened.

What could be different about this js file?

Would our Smoothwall system be objecting to a resource referred to INSIDE that javascript file?

Likely, but it’s hard to find out because the code at is obfuscated.