Can't launch a program

trying to launch a simple script, but replit won’t start. There is some output on the console on the first try and then nothing. After taking a quick screenshot when the output was visible I saw that there is a conflict with packages “because python-template depends on both replit (^3.2.4) and dcyw-utilities (^0.1.0.0), version solving failed”
But its a brand new replit, any help appreciated.
Also how do we contact support here?

Replit should really update their package, but in the meantime you can follow this:

1 Like

Thanks for trying to help, I ran your command (got an error, see below).

poetry add git+https://github.com/noneofyourbusiness1415252/replit-py


  CalledProcessError

  Command '['git', 'config', '-l']' returned non-zero exit status 1.

  at venv/lib/python3.10/site-packages/poetry/utils/_compat.py:217 in run
      213│                 process.wait()
      214│                 raise
      215│             retcode = process.poll()
      216│             if check and retcode:
    → 217│                 raise CalledProcessError(
      218│                     retcode, process.args, output=stdout, stderr=stderr
      219│                 )
      220│         finally:
      221│             # None because our context manager __exit__ does not use them.

The thing is my script was working all fine a week ago, not sure what changed with Replit’s packages but I’ve spent 2 days trying to figure and its a pain to deal with old packages. I’m moving to CodeAnywhere now

This happened last time too… Try this:

2 Likes

Hi @idris5, welcome to the forums!

Email support@replit.com or contact@replit.com

2 Likes

Thank you, I’ve tried all the suggestions in your link but no luck.

Here is the output of this command:
poetry add -vv git+https://github.com/noneofyourbusiness1415252/replit-py

Using virtualenv: /home/runner/DownrightLikelyAddons/venv

Updating dependencies
Resolving dependencies...
   1: fact: repl-nix-downrightlikelyaddons is 0.1.0
   1: derived: repl-nix-downrightlikelyaddons
   1: fact: repl-nix-downrightlikelyaddons depends on pytz (^2023.3)
   1: fact: repl-nix-downrightlikelyaddons depends on EbookLib (^0.18)
   1: fact: repl-nix-downrightlikelyaddons depends on langdetect (^1.0.9)
   1: fact: repl-nix-downrightlikelyaddons depends on openai (^0.27.8)
   1: fact: repl-nix-downrightlikelyaddons depends on prawcore (^2.3.0)
   1: fact: repl-nix-downrightlikelyaddons depends on tweepy (^4.14.0)
   1: fact: repl-nix-downrightlikelyaddons depends on gradio (^3.34.0)
   1: fact: repl-nix-downrightlikelyaddons depends on html2text (^2020.1.16)
   1: fact: repl-nix-downrightlikelyaddons depends on bs4 (^0.0.1)
   1: fact: repl-nix-downrightlikelyaddons depends on feedparser (^6.0.10)
   1: fact: repl-nix-downrightlikelyaddons depends on dycw-utilities (^0.10.0)
   1: fact: repl-nix-downrightlikelyaddons depends on praw (^7.7.0)
   1: fact: repl-nix-downrightlikelyaddons depends on requests (^2.31.0)
   1: fact: repl-nix-downrightlikelyaddons depends on replit (3.2.5)
   1: selecting repl-nix-downrightlikelyaddons (0.1.0)
   1: derived: replit (3.2.5) @ git+https://github.com/noneofyourbusiness1415252/replit-py
   1: derived: requests (>=2.31.0,<3.0.0)
   1: derived: praw (>=7.7.0,<8.0.0)
   1: derived: dycw-utilities (>=0.10.0,<0.11.0)
   1: derived: feedparser (>=6.0.10,<7.0.0)
   1: derived: bs4 (>=0.0.1,<0.0.2)
   1: derived: html2text (>=2020.1.16,<2021.0.0)
   1: derived: gradio (>=3.34.0,<4.0.0)
   1: derived: tweepy (>=4.14.0,<5.0.0)
   1: derived: prawcore (>=2.3.0,<3.0.0)
   1: derived: openai (>=0.27.8,<0.28.0)
   1: derived: langdetect (>=1.0.9,<2.0.0)
   1: derived: EbookLib (>=0.18,<0.19)
   1: derived: pytz (>=2023.3,<2024.0)
   1: fact: replit (3.2.5) depends on typing_extensions (^4)
   1: fact: replit (3.2.5) depends on Flask (^2.0.0)
   1: fact: replit (3.2.5) depends on Werkzeug (^2.0.0)
   1: fact: replit (3.2.5) depends on aiohttp (^3.6.2)
   1: fact: replit (3.2.5) depends on requests (^2.25.1)
   1: fact: replit (3.2.5) depends on pyseto (^1.6.11)
   1: fact: replit (3.2.5) depends on protobuf (^4.21.8)
   1: selecting replit (3.2.5 4f1aa7d)
   1: derived: protobuf (>=4.21.8,<5.0.0)
   1: derived: pyseto (>=1.6.11,<2.0.0)
   1: derived: aiohttp (>=3.6.2,<4.0.0)
   1: derived: Werkzeug (>=2.0.0,<3.0.0)
   1: derived: Flask (>=2.0.0,<3.0.0)
   1: derived: typing_extensions (>=4,<5)
   1: Version solving took 0.049 seconds.
   1: Tried 1 solutions.

  Stack trace:

  33  venv/lib/python3.10/site-packages/cleo/application.py:327 in run
        exit_code = self._run(io)

  32  venv/lib/python3.10/site-packages/poetry/console/application.py:190 in _run
        exit_code: int = super()._run(io)

  31  venv/lib/python3.10/site-packages/cleo/application.py:431 in _run
        exit_code = self._run_command(command, io)

  30  venv/lib/python3.10/site-packages/cleo/application.py:473 in _run_command
        raise error

  29  venv/lib/python3.10/site-packages/cleo/application.py:457 in _run_command
        exit_code = command.run(io)

  28  venv/lib/python3.10/site-packages/cleo/commands/base_command.py:119 in run
        status_code = self.execute(io)

  27  venv/lib/python3.10/site-packages/cleo/commands/command.py:62 in execute
        return self.handle()

  26  venv/lib/python3.10/site-packages/poetry/console/commands/add.py:271 in handle
        status = self.installer.run()

  25  venv/lib/python3.10/site-packages/poetry/installation/installer.py:104 in run
        return self._do_install()

  24  venv/lib/python3.10/site-packages/poetry/installation/installer.py:241 in _do_install
        ops = solver.solve(use_latest=self._whitelist).calculate_operations()

  23  venv/lib/python3.10/site-packages/poetry/puzzle/solver.py:72 in solve
        packages, depths = self._solve()

  22  venv/lib/python3.10/site-packages/poetry/puzzle/solver.py:155 in _solve
        result = resolve_version(self._package, self._provider)

  21  venv/lib/python3.10/site-packages/poetry/mixology/__init__.py:18 in resolve_version
        return solver.solve()

  20  venv/lib/python3.10/site-packages/poetry/mixology/version_solver.py:164 in solve
        next = self._choose_package_version()

  19  venv/lib/python3.10/site-packages/poetry/mixology/version_solver.py:480 in _choose_package_version
        dependency = min(*unsatisfied, key=_get_min)

  18  venv/lib/python3.10/site-packages/poetry/mixology/version_solver.py:464 in _get_min
        self._dependency_cache.search_for(

  17  venv/lib/python3.10/site-packages/poetry/mixology/version_solver.py:109 in search_for
        packages = self._search_for_cached(dependency, key)

  16  venv/lib/python3.10/site-packages/poetry/mixology/version_solver.py:92 in _search_for
        packages = self._provider.search_for(dependency)

  15  venv/lib/python3.10/site-packages/poetry/puzzle/provider.py:287 in search_for
        packages = self._pool.find_packages(dependency)

  14  venv/lib/python3.10/site-packages/poetry/repositories/repository_pool.py:192 in find_packages
        packages += repo.find_packages(dependency)

  13  venv/lib/python3.10/site-packages/poetry/repositories/repository.py:40 in find_packages
        for package in self._find_packages(dependency.name, constraint):

  12  venv/lib/python3.10/site-packages/poetry/repositories/pypi_repository.py:114 in _find_packages
        json_page = self.get_page(name)

  11  venv/lib/python3.10/site-packages/poetry/repositories/pypi_repository.py:216 in _get_page
        info = self.get_package_info(name)

  10  venv/lib/python3.10/site-packages/poetry/repositories/pypi_repository.py:105 in get_package_info
        return self._get_package_info(name)

   9  venv/lib/python3.10/site-packages/poetry/repositories/pypi_repository.py:129 in _get_package_info
        info = self._get(f"simple/{name}/", headers=headers)

   8  venv/lib/python3.10/site-packages/poetry/repositories/pypi_repository.py:223 in _get
        json_response = self.session.get(

   7  venv/lib/python3.10/site-packages/poetry/utils/authenticator.py:289 in get
        return self.request("get", url, **kwargs)

   6  venv/lib/python3.10/site-packages/poetry/utils/authenticator.py:260 in request
        resp = session.send(prepared_request, **send_kwargs)

   5  venv/lib/python3.10/site-packages/requests/sessions.py:703 in send
        r = adapter.send(request, **kwargs)

   4  venv/lib/python3.10/site-packages/cachecontrol/adapter.py:48 in send
        cached_response = self.controller.cached_request(request)

   3  venv/lib/python3.10/site-packages/cachecontrol/controller.py:155 in cached_request
        resp = self.serializer.loads(request, cache_data, body_file)

   2  venv/lib/python3.10/site-packages/cachecontrol/serialize.py:95 in loads
        return getattr(self, "_loads_v{}".format(ver))(request, data, body_file)

   1  venv/lib/python3.10/site-packages/cachecontrol/serialize.py:190 in _loads_v4
        return self.prepare_response(request, cached, body_file)

  TypeError

  HTTPResponse.__init__() got an unexpected keyword argument 'strict'

  at venv/lib/python3.10/site-packages/cachecontrol/serialize.py:141 in prepare_response
      137│             #
      138│             #     TypeError: 'str' does not support the buffer interface
      139│             body = io.BytesIO(body_raw.encode("utf8"))
      140│ 
    → 141│         return HTTPResponse(body=body, preload_content=False, **cached["response"])
      142│ 
      143│     def _loads_v0(self, request, data, body_file=None):
      144│         # The original legacy cache data. This doesn't contain enough
      145│         # information to construct everything we need, so we'll treat this as

Ah! I actually know how to solve that one. Try this:

No luck, same issue :cry:

The 2nd one didn’t do much though:
poetry add urllib3==1.26.15

Updating dependencies
Resolving dependencies... (3.0s)

No dependencies to install or update

Writing lock file
1 Like

That’s actually a good sign :slight_smile:
Try this now:

Thank you, it updated the dependencies but I still have the same error.
In the meantime I managed to get all my scripts running fine on Codeanywhere now so I think I’ll just use that instead. Too bad I paid for a year of Replit already.
Anyway thanks a bunch for at least trying to sort me out!

Which Error? The original one with replit, a TypeError, or something else?

The original one yeah: nothing seem to happen, no output in the console

Huh. Try adding the package you need in Shell (poetry add package-name), as that won’t clear after an error.

2 Likes