Can't install the moodle package

Hi, I’m trying to install the moodle package (moodle 0.0.1) but I always get an installation error. Does anyone know how to solve it?

Hi @AngelIvanov2 , welcome to the forums! Have you tried entering pip install moodle in the Shell?

1 Like

yes, throws an error again

ERROR: Could not find a version that satisfies the requirement moodle (from versions: 0.0.1)
ERROR: No matching distribution found for moodle

Are you sure moodle is a library? I’m assuming you are using Python.

yes, I’m using python and moodle is in the package list, I tried to use the “install” button first, assuming it was working, but no… moodle · PyPI

Have you tried poetry install moodle yet?

poetry add moodle results into the bellow:

Hmm… that is odd. As far as I can see, moodle is a module that you can install with pip install moodle, so I’m not sure why it doesn’t work.

@AngelIvanov2 Maybe you can try to create a new repl and see if pip install moodle works in the new repl?

no, any other ideas?

Erm… pip install python-moodle? Or poetry install python-moodle (Idk if the second works)