Can't install/import scratchattach Python module

Bug description:
I cannot use the “scratchattach” module in my Python project: however I install it, it says “module not found” when I run my script.

Expected vs Current Behavior:
The module should install/import properly. Instead, it throws many errors when installing, and then doesn’t import when I run my script.

Steps to reproduce:

  1. Create a Python project
  2. Try install the “scratchattach” module with the “pip install scratchattach” command through the console tab (you may need to select a version of pip the first time)

Bug appears at this link: ScratchManager_Backend - Replit

Screenshot(s)/Screen Recording:

Browser/OS/Device: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/119.0.0.0 Safari/537.36 Edg/119.0.0.0

Replit Profile: https://replit.com/@fancyfinn9

Hi @fancyfinn9 , welcome to the forums!
Try running poetry add scratchattach in the Shell.
Hope this helps!
If that doesn’t work, runpip install --upgrade pip then pip install scratchattach. Use this only if the very first method doesn’t work.

2 Likes

:point_up: before that, run in Shell:

nix-editor -hr pkgs.python39Packages.pip

I’d recommend not to use pip directly on replit.

1 Like