Can't deploy,error

Question:
The deployment failed to initialize due to a configuration or code error. Possible wrong run command but cannot identify which one to use.
Repl link/Link to where the bug appears:
https://replit.com/@AncestryDNA/admix
Screenshots, links, or other helpful context:

code snippet

Hi @AncestryDNA , welcome to the forums!
Could you send the logs of the deployment here?
Also, what is your deployment method? Your repl seems to be a Python package.

Hi, yes is Python, please see logs attached

Hi @AncestryDNA !
2 things:

  1. You seem to deploying your repl as a webserver. As there is no port/server, the deployment won’t run.
  2. What is the purpose of deploying your repl, if I may ask?

I need to embed software to my website. I have used multiple “run” commands, none of them worked. The code is forked from github and uploaded to replit. Can you please advise which command I should use as a run command?

Does the repl have a website?

What? I need to embed to MY website. I have deleted previous deployment and started new. It is asking me for run command. I tried multiple commands and they are not working. Just help me to deploy please, don’t worry about the rest. Thanks

No, because the issue is the purpose of your repl. You won’t need to deploy it unless it functions as a bot.
So I ask again, what is the purpose of your repl?

I need an embed code to integrate python script to wordpress website. According to Replit help section, I can get this once replit is deployed.

@AncestryDNA I see, thanks for the clarification.
You could try deploying as a Reserved VM, Background worker.

look mate, it is asking me for a “run” command. I’ve entered python setup.py and this is what I get. When I run script with this command there is an error. I cannot deploy without being able to run script first:


What would be “run” command please? Can you please help or not?

If this is for packaging, I would suggest using poetry instead of setup.py.
Your run command could be pypi_upload.sh maybe?

Tried that as well. It is not working

Hmm… what about bash pypi_upload.sh? Or use poetry instead of setup.py if it’s a package?

We might be close. Try entering poetry add twine in the Shell.

Try the command above first, if it doesn’t work, try configuring your pyproject.toml.

Done that. It worked I guess. Do I need run command now to deploy?

You probably won’t need to deploy your repl since it’s a package. You could try, but you’ll need to change the version every time the program runs, or you may get errors since it runs over and over (version errors).

1 Like