Can't access custom domain or IP address

I have attempted to connect a custom domain but i get

This site can’t provide a secure connection sent an invalid response.


Replit Profile:

(cant put in enough links in first post)
It works fine at:

Hi @tzonov , welcome to the forums!
You’ll need to link a CNAME and TXT record to the website, or a A and TXT record.
Hope this helps!
The linking tools are in the Webview tab.

I was only able to put one link in my first post, so i have added them as replies

Hey @tzonov !
Could you try what I suggested?

Oh, sorry, i understand now. Yes I have done that. I have also unlinked and retried a few times.

Screenshot 2023-09-01 at 3.04.26 pm

And that does not work?

Thats right, see

@tzonov May I know which records you have used?

you should be able to see them in my original replies:

Hey @tzonov !
Domain linking on replit can take up to 2 days. I suggest you wait it out, and see what happens.

Ok, thanks. I first tried it yesterday. I assume I should wait another 2 days after I linked and unlinked it?

In the meantime, shouldnt I still be able to see it at ? (I can’t)

1 Like

You should not, as I believe that would be the IP of one of Replit’s load balancers. Without the domain name or the TXT record, Replit doesn’t know what Repl you want.

Could you try linking with an A and TXT instead of CNAME and TXT? I usually have more success with A records.

Thanks for the response. Please see the rest of the thread, I am using A and TXT

1 Like

It’s been more than 2 days, and I have possibly exhausted the support options through the forum - is there a way to escalate to replit staff?

Are you trying to link a custom domain to your deployment ( or the development version (

From the screenshot, it looks like you linked it to the development version (unless you’re on mobile, the deployment domain link form is much larger), but you said that works, which is a deployment

This is a really good point! I am trying to link to the deployed version, but now that I look closely I can see that maybe its linking to the development version.

If so, why doesnt that work anyway? And, how would i even link to the deployed version? I cant see how thats even possible in the current interface, and its not covered in the ‘Help’ at all.

Im on desktop, I just took a screenie of the bit I thought was relevant.

I’m honestly not sure. An SSL error is really weird.

Try this:

Maybe that will somehow work? (just remember to unlink the old one)

Thanks! I hadn’t found that help.

An SSL error is really weird

Thats my specialty…

I have made the changes and now its that waiting game to see if it worked. I guess I’ll try to dig further into my SSL if it still doesnt.