Cannot open replit.nix file

Problem description

I tried to click the “Open replit.nix file” button in the System dependencies panel. It doesn’t do anything. I’m trying to upgrade Node.js from v16 to v20.

I tried this in Chrome v121 and Firefox v122

Expected behavior

Some kind of editor for the replit.nix file should open.

Actual behavior

Nothing happens

Steps to reproduce

Open System dependencies panel
Try to click “Open replit.nix file”

Browser

Chrome v121, Firefox v122

OS

macOS

Device if mobile

N/A

Plan

Free tier

Hi @adidahiya , welcome to the forums!
In your Files sidebar, click the 2 dots at the top, then click on Show Hidden Files. Scroll to the bottom of the files list and check if the replit.nix file exists. If it doesn’t, try making a new one.

5 Likes

Thanks @NateDhaliwal, that worked. I was able to edit the replit.nix file after showing hidden files. Note that the button in the System dependencies panel still doesn’t work after I do this, though; I think there’s a UI bug there.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.