Cannot format/rename symbol

Bug description:
Sometimes, the editor fails to format or rename symbols.

Steps to reproduce:
Click on “Format code”
Click on a name and press “F2”

Bug appears at this link:

Screenshot(s)/Screen Recording:

Browser/OS/Device: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Replit Profile:

It seems to run in my mind that you have to run the repl once first. Have you tried that?

I ran it 10 times before…

I can’t currently reproduce the issue on a fork of your repl. WinAltG on Windows to record what just happened might make it easier to see what triggers the issue. Or, if you add ?debug=1 to your repl, you could open the Debug tool and we can see if there are any abnormal LSP logs.
Next time it happens, you could try running in Shell:

pkill .typescript-lan

Or, if that doesn’t work, the classic kill 1 to reboot the repl.

1 Like

Thanks! Anyways, it doesn’t always happen, but when it happens, also code intelligence stops working.

1 Like