Cannot access REPL after download

Problem description:
I tried to download a REPL of mine. The file downloaded appears to be corrupted, while the original REPL is completely inaccessible.

Popup notice

You can’t run this Repl right now.

This Repl is unavailable at the moment.
If you are the owner of this Repl and believe you should be able to run it, please contact support.

After a while it was accessible again but the download bug recurred.

Expected behavior:
I should have been able to download my REPL and access it afterwards.

Steps to reproduce:
Create a (Python?) REPL and then try to download it as zip.

Latest version of Chrome on Windows 10.

A link to the repl (not invite) or screenshots would be helpful.

1 Like

Here it is:


Here’s the link:

A link actually doesn’t help much, given that, unlike in the IDE, the viewer doesn’t have a download button.

A user can fork and test using the exact same Repl, hence the use of the Repl link in many circumstances.


I was unable to reproduce the issue of downloading a new python repl. Can you send me the link to your repl so I can investigate?

1 Like

I wonder if these are two separate issues. The inaccessible Repl is something that happens occasionally for various reasons (or no reason). Forking the Repl and using the fork may be a workaround. As for the corrupted download, perhaps you attempted to access the ZIP contents before the download was complete, i.e., there is missing data?

1 Like

Somehow only old Repls of mine (and their forks) are affected. Here it is.

I tried multiple times and not even once I get anything other than a .breakpoints file. I can successfully download newly created Repls, however, as stated above.

The Repl downloaded as a .breakpoints file? I’ve never heard of that. Mine download as .ZIP files.

I did get a wrapper .zip file; it contains the .breakpoints file but nothing else.

i am having the same issue:


please help me Matt:

for me it downloads the files as it is in my repl

@Parker2991 It downloads the files not as a ZIP? That might be a bug.

oh .zip i thought you were talking about downloading the files by its self lol

1 Like

@SocietasLittera Can you please include the link to your Repl? Sometimes you can’t access a Repl because it violates the ToS. If this is the case, it’s possible that Replit is messing up your downloads on purpose (I don’t know that but it makes sense).

it did it to me when i tried to take a course

See this post. The Repl hardly has any content (just one placeholder function) so violation of ToS is unlikely to be the reason.