Can not install python package

Problem description:
I cannot install the python package by clicking the package icon in the sidebar and console.

Expected behavior:
Install success

Actual behavior:
Nothing happens

Steps to reproduce:
Click at the package icon and search pydantic and click install

Bug appears at this link:

Google Chrome/MacOS Version 111.0.5563.110 (Official Build) (x86_64)

Hey @ddotx! Welcome to the community!

If you are unable to find the module you want to install, you will need to install it manually via the shell:

$ pip install pydantic

This should install the module without any problems.

1 Like

It sounds like they can find it, but replit’s packager has issues installing it. (If I read the post right.)

He said he was not able to install it via the console (which is NOT where you are suppose to install modules) and the Packages tab.

I’m guessing he’s referring to the fact that the output of the packager goes to the console, but I could be wrong.

You are very wrong :man_facepalming:. He already mentioned that he was not able to find and install the module from the Packages tab and console.

This implies that he did in fact find it, why else would he mention clicking install here?

Okay, I tried installing it and it worked for me.

So then it’s just an internet connection issue, however it’s still best to install modules from the shell since you can track the progress and gives more information if it fails.

1 Like

Yeah! I can install via shell with pip install but at the time I posted I cannot do that.

Btw I still cannot install on package view

1 Like

From looking at the image they posted, they installed it with the packager, meaning it might have been a temporary bug, or, like they originally mentioned, an internet issue.

Regardless of the cause, if your issue is now resolved, please mark whichever post you found the most helpful with this problem as the solution.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.