Can anyone tell why is this issue here when trying to install libXrender?

Hey can anyone help me on this, when I try to install a package via nix, I get this error:

Can you try putting pkgs.xorg.libXrender instead of pkgs.libXrender? (Then refresh.)

1 Like

Now getting below error

Try this:

{ pkgs }: {
  deps = [
    pkgs.xorg.libXrender
    pkgs.xorg.libXfixes
    pkgs.xorg.libXext
    pkgs.libxkbcommon
    pkgs.xkeyboard_config
    pkgs.xorg.libxcb
    pkgs.libxml2
    pkgs.xorg.libX11
  ];
}

Use search.nixos.org to find the correct packages, or equivalently, use the System Dependencies tool to find and install packages.

2 Likes