Can anyone help please ? /nix/store/zqk3m21442kvpjwd3

Question:

Repl link:

code snippet

/nix/store/zqk3m21442kvpjwd3rh41wdavqkzkyik-python3-wrapper/bin/python3 $file
what dose this mean ???

It’s just a quirk of the new template. It’s safe to ignore, but if you’d like it to not show up, add this to line 1 of your .replit file:

run = "clear&&python main.py"
2 Likes

I have the same problem, and adding this line to my .replit file doesn’t help. With or without the line, main.py is not run. And the console is not running Python, but bash.

Oh. Please give a link to your repl.

Here it is: https://replit.com/@kaufmann/PreciousMulticoloredTechnology?v=1
Adding your suggested line to .replit gets rid of the cryptic message, but doesn’t start python. The console does accept and run shell commands.

I see the code, you didn’t change the .replit file at all and even if you did the thing is completely empty

Yes, it’s a blank repl with an empty main.py. I created it after I noticed the problem with all my existing repls.
I just noticed that code in main.py does get executed. But once that is done, python stops and the console runs bash. Variables or functions that were defined in main.py are lost.

1 Like

https://replit.com/@manickimpressiv/NewProjectIssue
I am having this same issue, it was not there two days ago. Now I can not make it go away, I have tried to insert the commands, but I am in the middle of my first programming class, and that will give me a fail grade for the assignment I have to do.

I don’t think it will, since the issue happens in every new (modules-based) Python repl and won’t come in any I/O tests. Following is a solution but if you use it, ensure that you remove it if/when the issue for you is fixed (the solution might break in some scenarios or after updates to replit’s python module as it isn’t guaranteed to use replit’s python wrapper)