Bug Report : Chat On Repl

Problem Description :

Hey people,

I wanted to report a bug about the chat on a repl. Let me explain the issue, I’ve invited a person into the repl and wanted to talk with them, so I just wrote a @ on the input box and its username appeared. This is made so I don’t have to write the full username and it’s very helpful, but the problem is that when I clicked on it the username didn’t appear on the input!

Expected behavior :

As I said what I expect when clicking on the box appears when putting a @ in the input box the text isn’t appearing. What I should expect is this :

  1. The user writes a @
  2. A box with the photo and username of the invited person appears
  3. He clicks on it
  4. The username of that person is written automatically on the input

Actual behavior :

Here is the actual behavior :

  1. The user writes a @
  2. A box with the photo and username of the invited person appears
  3. He clicks on it
  4. The username of that person is not written automatically on the input

The problem is that the username is not written.

Steps to reproduce :

To reproduce this you should follow these steps :

  1. Create an HTML, CSS and JS repl
  2. Click on the invite button and add a user or invite via link
  3. Open the chat
    image
  4. Write a @ on the chat until you see the image and username of the invited user
  5. Click on the box with the username and photo of the invited user, what you would expect is it’s username to appear on the input, but it doesn’t appear!

Bug appears at this link:

For this bug, I can’t provide a link since it’s an inside repl workspace problem! It can only be reproduced to see the bug.

**Video Proof : **
Bug

Browser/OS/Device :

I’m currently using Chrome and I’m on an MSI laptop that uses Windows, also I’ve tested this on Edge and the same problem happens. I’ve also tried this with Safari, on a Macbook which uses IOS.

I hope this can get resolved since it affects a lot of people who work with other people with Replit!

3 Likes

Thanks for this amazing bug report Hugo! We have filed it with our engineering team.

2 Likes