Browser wont recognize .webp html files

When attempting to optimize load time for images, I converted all images to .webp format. However, any browser I use will not load or only loads the old jpg files.

Repl link: Contact

Your website hasn’t updated to host the webps, because they were generated programmatically. Every time you convert images, rename the images folder then rename it back, and do a similar process for any filesystem changes made without using the workspace UI (including changes made by Git or the Shell).


tried that but no luck. also after changing directory name, it continued to load from the “image” folder even though i had changed the directory name to something else :face_with_raised_eyebrow: could it be something blocking me within the repl IDE?

ensure you re-run the repl as usual after you rename the directory back

1 Like

Still no luck unfortunately. Could it have something to do with Nix? I had to use nix in order to export to .webp format within the shell.

looks like you were using the shell to rename? It has to be done through the filetree in the sidebar for it to register

1 Like