Browser error intermittent: Python with Turtle

I’m seeing an issue with the Turtle output on some Python Repls. I am teaching students in Teams for Education. One student will start a project and run things successfully, the next will see the following error:

image

Sometimes refreshing the page or restarting the browser will resolve the issue, but usually it is persistent for the student. I’m even seeing, through my teacher account, that a project that was successful on the student side is working for me when viewed in my teacher account, and a project that was failing for a student is also failing for me. (But when I fork the project, it works in this case.)

About a month ago, @shaneatreplit was inviting links to Repls that are exhibiting the issue. I can provide these links to administrators, but they are private Repls containing student work, so I’m not sure I should share them here, initially.

Actually, this means that we cannot view them, the Replit staff might be able to.


Could you make sure that the replit.dev domain is unblocked, or try entering kill 1 in the Shell?
Hope this helps!

this means that we cannot view them

Well, that is why I offered to provide the links “to administrators”. :sunglasses:

This seems to be an ongoing issue that has been coming up since Summer '23. I have seen a number of threads which have closed (so I can’t add my voice) and don’t offer any steps to fix. Moreover, in my situation I have a repl which is working, and two repls that have been forked from it: one works, and one doesn’t. Then when I fork the one that fails, the forked fork works.

Edit @NateDhaliwal: When I posted the above, I missed the bit after the horizontal rule. I just pulled up both repls.

  • Initially, they both showed the error, when yesterday only one was.
  • When I ran each one, it still showed the error.
  • When I clicked Try Again, they both worked (no kill needed).

I will ask my IT department, but more than half of my students are just Turtling away without issue, so I really don’t see why it would have anything to do with domain blocking.

2 Likes

Nate meant that because they’re private, even if you publicly share links to them, we cannot view the Repls.

Example, you and I can’t view this Repl:

1 Like

even if you publicly share links to them, we cannot view the Repls.

That’s why I didn’t share them here, @Firepup650. I understand that private repls cannot be viewed by other users. Sorry if that was not clear enough. Regardless, it is clear to me that it is not an issue with the repl, so sharing the links is a moot point.

@NateDhaliwal My IT department as confirmed that the domain replit.dev is not blocked on our network.

2 Likes

People have said that just spamming Try Again has worked for them. Never encountered this issue personally, but Try Again should work with other students, like it did in your case.

1 Like

Hi.

There are two cases for the Output error (errors also occur for Webview, as they have the same domain):

  1. The error is intermittent or sporadic. It usually happens when a repl is opened, or a repl disconnects (for any reason).
  2. The error always happens → the Output domain *.replit.dev is probably blocked, usually by the network. (Historically, replit could potentially be used for proxies. This is harder in modern replit. Using firewalledreplit.com prevented this issue, but I’m not sure if this is still the case.)

If the error is intermittent, try this:
This error cannot go away unless the program is running when the Output is ‘refreshed’.
Ways to ‘refresh’ the Output (must be while program is running and displaying stuff):

  • Click the Try again button
  • Close the Output tab in the editor, then open it back up from an editor New Tab or Tools.
  • Refresh the browser tab (do not stop the program)

Other solutions and context:
Forking the repl may also work.
firewalledreplit.com used to be the solution when the domain was blocked, but no longer.

Important note (especially for turtle):
For most repls: if the program ends, the graphics or produced image disappears. This would also prevent someone from fixing an intermittent Output error. To fix this, simply prevent the program from exiting at the end:

  • Put input() or turtle.exitonclick() or turtle.mainloop() at the end of the program
  • Use configuration that does not exit at the end of the program (this configuration is present by default in very old repls, or it can easily be set).
3 Likes

Thanks very much to @NateDhaliwal for your additional thoughts. This last response from @NuclearPasta0 is much more comprehensive than anything I’ve seen in a related thread, and I appreciate that a lot! For my students and I, the issue is definitely sporadic.

I can’t say for sure, but my initial experiences with this issue were probably hampered by clicking Try Again or refreshing the page when the repl wasn’t running. At the time, that didn’t occur to me as a factor, but I see in retrospect why it’s relevant. This would explain why we couldn’t get the error to go away. I have class on Tuesday and Thursday, so we’ll see if I have any more experiences with my students before seven days is up.

4 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.