Bot Not Running 24/7 on Hacker Plan


I am currently facing an issue with running my bot continuously on the Hacker plan. Despite having the plan activated, my bot doesn’t seem to run 24/7 as expected.

Here’s a brief overview of my setup and the issue:

  1. Bot Description: My bot, written in Node.js, monitors blockchain transactions and sends notifications via Telegram. It is supposed to run continuously to check for new transactions.
  2. Plan Details: I am subscribed to the Hacker plan, which, as I understand, should allow my bot to run uninterrupted.
  3. Issue Observed: The bot stops executing when the Replit window is closed, and I do not see the “Always On” feature in my settings, which I believe is essential for continuous running.
  4. Error Logs: The bot shows connectivity errors at times (ECONNRESET errors), possibly indicating intermittent network issues or problems connecting to the Alchemy API.

I would appreciate any guidance on the following:

  • How can I enable the “Always On” feature for my bot on the Hacker plan?
  • Are there known issues or additional settings that I need to adjust to ensure continuous operation?
  • Any insights into handling the ECONNRESET error more effectively?

Here’s link to my code:


Our Always On features have been deprecated and that functionality is now in our Deployments product. Take a look at our docs here:



I deployed my project, but it is not running 24/7. Only runs if the browser window is open. Any advice?

Did you use a Reserved VM deployment? Those are the onlyones that are always on.

Ahhhhhh I see, I fixed it, and it works now!! Thank you so much! :slight_smile:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.