Autoscale is not passing Promotion step

The Problem?
Everything but Promote is working.


1 Like

I tried deploying it today, and it worked.
Which is unfortunate, because it spammed a few servers and spent 30,000 of my compute units doing whatever it was doing the day before.

Hoping this won’t reoccur!

I have found out that this was happening because I had ports set for the .Replit in the current Node.js template.

So far, I cannot set any ports there at all.
Is it possibly a reason for my Deployment performance to be tanking?

Is this working now then? What is your need for setting the ports in the .replit file?

Happy to walk you through this over the phone if you prefer. Sign up here: Calendly - Replit Deployments Team


I read in multiple places on Replit that these ports are used for deployments.

And it seems changing them does effect them.

I was trying to figure out why it wasn’t working,
And so I added and then removed them, the next day the Repl deployed.

But it seems that isn’t the only issue with deployments.

And my issues are still unchanged.

I still have a big difference between running and deploying.

Sorry for the vague reply, I’m busy working.
It should actually make sense now.

Running a Discord bot on Autoscale won’t work very well. Bots are one of the use cases where it makes more sense to use a Reserved VM.

I’ll respond in the other thread. It will be much easier for us if you can keep a single thread with all of the issues you are facing for us to respond to, rather than opening new issues for everything.