Auto Tabs Driving Me Nuts

I am coding in various languages (C/C++, JS, Python) and the Settings seems to not do much nor have the flexibility to control tabs very well.

I do NOT want replit to auto tab when I hit return. But, no matter what I do I can’t stop it. I have turned off all the code intelligence, played with tabs, spaces, etc. But, there doesn’t seem to be a way to tell replit to STOP tabing when I hit return or when it “thinks” there should be a tab. Its ALWAYS wrong, I do NOT want its help :slight_smile:

Is there another set of settings I am missing? other than “Settings”?

Can you show an example of where it is wrong? I know some languages in replit completely just add tabs practically randomly but mainstream languages like python, c++ and js should work.


For example, while working in .HTML or .js, or .css for project, all of them when you have a blankline and hit return, the editor autotabs down, something like this:

line 1: On this blank line I hit return
line 2: The editor auto TABs (4 spaces) _ ← cursor end up here, tabbed over

So, every time I hit return, the editor tabs over, instead of returning to the start of line. This happens with blank code lines which is driving me nuts.

In python when I type a block and end with a “:”, I don’t mind a tab since its required, but the behavior I am seeing is no matter what language, what file extension, if you hit return, then the editor moves to next line and tabs for you.