An error occurred while trying to play sound

I read Replit docs and tried to play a sound, that I already uploaded as another file in my repl(Click.mp3), but I get really strange error. What’s the problem is going on here?

Welcome to the forums! Could you please provide a link to the Repl?

Yes, of course. I first tried using this command in my main project, then got an error and did the same in a separate project. The situation was the same there, although I tried toggling the “Explorer” mode on and off. After surfing the forum I found several other similar situations that never got a solution. Is this a problem on the Replit side or are we just misunderstanding something? Link:

1 Like

note that you can’t make replit audio work for accounts which don’t have edit access to the repl, or on Safari. Since all you’re using is a single click sound, see if the sound that this produces suits your purpose:


To make playing audio files work:

  1. Click Files ⋮ > Show hidden files, .replit
  2. Add a line to the start
1 Like

I didn’t understood your instructions, fox example, where is .replit here?**


oh wait, forgot you’re on a non-nix repl. I guess nix migrations don’t happen on mobile app yet.
Create a .replit file.

1 Like

One more thing! I tried to run it online at this webpage and code worked. This problem is happening only in replit app. But I want to found a way to play sounds and it app.

Okay, I done it, what’s next?

then re-run the code and if audio is supported in the mobile app, it should work

I don’t think so…

oh, run kill 1 in Shell then try

I done it a few times, but first I get an error from this picture, and after the same problem was occurred.