“Always on” replit keeps disconnecting

Problem description:
I am hosting on replit a bot I created for an application called “highrise” and also set it to “always on” but it keeps stopping and not starting back automatically. This is the bot:

Expected behavior:
The bot should stay online and not disconnect

Actual behavior:
The running stops and I get “error connection with id closed”

Steps to reproduce:
I set it to always on, I run it and when i came back, its stopped

Bug appears at this link:


Safari on iphone

I think you should use Deployments instead, they don’t turn off. But some members of the staff team have been notified so hopefully this can fix this soon.


How to use the deployments

1 Like

Hello @aprogrammer97

I think that Always On is supposed to turn off sometimes (sneaky move from Replit) but there are two things you can do (and note that I don’t know much about bots, this is general advice)

Number 1: use a pinger like cron-job.org

It will keep your repl up for free and it won’t stop like Always On. There are options like UpTimeRobot (cron job is better) and building your own pinger (NOT RECOMMENDED)

2: deployments (I think)

qwerty said this but Deployments also keeps your repl up (mostly). IIRC it also stops sometimes.

Press “Deploy your project” after that. Then, choose a level (higher costs more). Purchase and deploy, and you will be deploying your project.

If you need more specific help then you should ask but note that I don’t know much about Deployments.


OP knows. OP’s problem is that it does not turn back on:

Deployments do not.


Yes, @QwertyQwerty88 is correct. Always On turns off when your repl is inactive, in order to save resources.


Hello thank you! How to use the pinger exactly if you know? What code to write there?

No code. Here are some steps:

  1. go to cron-job.org

  2. Sign up

  3. Press create cronjob

  1. basically copy these settings

Replace title and url with your project’s url and preferred title

Press “Create”

and you’re done. Now your project will be constantly up.

Maybe this will help with your problem.

Our Always-On product does not use dedicated VMs and therefore are not reliable. We will be deprecating it in the future.

You can switch to Deployments, which will provide your Repl with a dedicated machine which will not go to sleep.


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.