Always On Flask server doesn’t wake up when receiving traffic

My Flask server seems to not wake up when it receives http traffic. It has “always on” enabled.

This is the repl:

I’ve linked it with this custom domain:

It goes out multiple times a day. None of the endpoints wake it up. It needs to be manually restarted by pressing the start button each time.

What’s going on here?

Hi @noquinn!
Always-On repls will turn on if the repl is inactive, in order to save resources.
If you want a true always on, try taking a look at Replit Deployments.


@noquinn the Repl will turn off but immediately turn back on if it does. It will be on even if it is inactive.


But the docs say that http traffic should wake the repl up. It doesn’t seem to be doing that. It’s acting like a regular repl without the always on boost.

I have an Express server with always on enabled as well. The Express server wakes back up when it receives traffic. This Flask server doesn’t.

I copied my server code into a new repl. Now it is behaving normally and being woken up by http traffic.

Same problem here, but with an Express server. I’m not using Always On, but it should still wake up when I visit the website.

Repl link: