Allowing VNC for Replit

Trying to permit VNC for Replit through a firewall but without allowing VNC for anything else as this would allow circumvention. The destination IP keeps changing so is there a way to force the same IP each time???

Previously, firewalledreplit.com would be used for this purpose as repls are blocked from internet access.
https://docs.replit.com/getting-started/firewalled-replit
Unfortunately, the VNC/Output/Webview for firewalled replit stopped working a few weeks ago and I think replit has not fixed it.

There is some information about how IP/domain of the VNC is generated and when it changes, I do not remember, but another community member could probably give you some info.

I’m interested in any solutions to this. My IT provider doesn’t want to enable VNC port 5900 access as they’ve said it’ll “open a back door”. I’d like to use replit for tkinter and turtle which both look like they’re using port 5900.
e.g.
wss:// .janeway.replit.dev:5900/

Any help or suggests would be greatly appreciated.

That doesn’t really make sense to me, you’re only connecting to a different machine (Replit) on that port, which does not open it on your end.


Sorry, probably my bad explanation. See the screenshot with the blocked socket. I didn’t know if there were any other options as my IT Techs won’t unblock the 5900 socket.

That doesn’t make sense, unless they’re somehow filtering external sites/devices, based on port. Which, AFAIK, isn’t a thing easily done, if at all. Can you open the same URL in a different tab? (Minus the port and wss://) If that fails, they’re just blocking the replit.dev site, not specifically a singular port on it.

2 Likes

When removing the wss:// and :5900 port from the address I get the Replit.com response “Hmm… We couldn’t reach this Repl, ## Make sure this Repl has a port open and is ready to receive HTTP traffic”