AI keeps generating text for me

Question:

I am trying to do a test for Angela Yu’s 100 Days of Python, but the replit AI keeps autogenerating the line for me. I want to actually write the code myself but it keeps showing me exactly what to do and I can’t turn it off

Repl link/Link to where the bug appears:
https://replit.com/@dphillip0809/tip-calculator-start#main.py
Screenshots, links, or other helpful context:

code snippet
2 Likes

Conveniently, in the replit editor in User Settings (find through Tools), there is a setting called “AI Code Completion” which enables/disables AI code completion for all repls.
In addition, that little AI icon near the bottom of the editor also brings up a setting to disable AI code completion for all repls.

5 Likes

:wave: Welcome to the forum @dphillip0809!

Simply press this button at the bottom of your screen:

image

Or as @NuclearPasta0 said, you can change it in the User Settings.

Hope this helped! :slight_smile:

5 Likes