AI autocomplete won’t turn off

Problem description:
AI generates code despite turning the feature off in settings. Does not respond to force quitting the app or logging out and logging back in.

Expected behavior:
The code stops being generated.

Actual behavior:
The code continues to be generated.

Steps to reproduce:
Start a new repl in the iOS app. Type anything.

Device: iOS
Plan: Free

Hi @SumyG1 , welcome to the forums!
Code Intelligence is not the same as AI Autocomplete. Code Intelligence is for hints as you type (like all the functions or variables that have the same letters you have typed), not the AI Autocomplete (the “ghost” text suggesting the lines of code).
You can’t turn off AI Autocomplete on mobile so try turning it off on a laptop or PC for that repl, and the change should be relected on the mobile app.
Hope this helps!

2 Likes

No, Code Intelligence is autocomplete. Just not AI autocomplete.

3 Likes

When I said ‘the autocomplete’, I meant the AI Autocomplete. I’ll edit the post.

That’s still wrong. Code Intelligence is not syntax highlighting. (Notice how after turning it off, you still see syntax highlighting?)

Well, that’s what the description of Code Intel that Replit put.

1 Like

I can’t tell if they combined the two.

Hey all!

To the original question, the option you’re looking for is “AI Code Completion”. Turn that off and the suggestions for what to type next will get turned off.

As for Code Intelligence, this is a fancy name for whatever Language Server gets run for whatever language you’re writing in. Syntax Highlighting is likely an oversight on that config option. You can see that when you turn it off, the LSP icon goes from a green check to an orange asterisk:

image

Hope this helps!

7 Likes

Follow-up, copy has been fixed as well :slightly_smiling_face:

4 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.