After NIX update discord bot in python does not run anymore

After NIX update the but loops with the following message:
File “”, line 2, in
import discord
ModuleNotFoundError: No module named ‘discord’
someone has an idea?

Repl link:

Traceback (most recent call last):

Are you using discord or py-cord?

Go to shell and do:
poetry add discord (if the package is discord)

discord i think.


poetry add discord
/nix/store/abvijrl56pyn7bvfggj6nlzrwz7l912a-nix-index-0.1.2/bin/nix-locate: /nix/store/s9qbqh7gzacs7h68b2jfmn9l6q4jwfjz-glibc-2.33-59/lib/ version `GLIBC_2.34’ not found (required by /nix/store/mdck89nsfisflwjv6xv8ydj7dj0sj2pn-gcc-11.3.0-lib/lib/
bash: poetry: command not found

The simplest way to fix that is to upload your files to a new repl


yes, that worked. but now i’ve lost my 8x boost from the initial package :thinking:

Did you use cycles or pro plan?

i have this hacker package… and in the beginning i had 8x boost for free on it… but it seems it has
developed at my disadvantage.

Cant you judt turn off the boost on that repl and turn it on on another repl?
I know you only have 1 boost. So first turn off on the old repl and turn it on on the new repl

yes for sure i already did that. but on the old one, x8 was enabled with no extra cycles needed. and on the new one i only can do x4. :unamused:


this NIX migration kicked me out of this benefit.

ah rip; atleast the code works i guess


yes, replit and code works now like a charm

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.