24/7 replit not working

i have a replit with always on active and it takes my cycles but after about 15 mins the replit turns off and it is still taking my cycles is there any way to get my cycles back? or just fix the bug entirely

This is not a bug; replit will force shut off your repls after a certain amount of down time. This is the nature of replit – there is no true 24/7 repls without external pingers (I recommend https://up.coding398.dev). What this means is there is a specific amount of down time that repl allows after which it will re-run your project. Essientally, “24/7” repls don’t actually ensure that it is run 24/7 but instead that you never have to press run – replit will do so for you; replit saves resources by doing this. It is annoying since sometimes projects such as web databases can be shut down and all the data is reset, but again, I point you to an external pinger.

then what is the point in always online it is legit lieing by the name surely there is legal action that can be taken aganst this ive lost money here

I don’t know, but it’s even worse since you can’t use uptimers anymore, you have to pay for that bad version that turns off half way and it’ll cost like so much XD

@bigminiboss You can’t use uptimers anymore?


Hey @AydenBG1!

Your Repl shouldn’t go to sleep if Always On is enabled. Can you send me the link to your Repl so I can take a look?

is it really not supposed to, I have noticed through rigorous testing that always on will, without fail turn off at some point, but, however, replit appears to turn it back on. (Testing is done through a var that has, after a few hours, reset, even though it should not have because the repl is always on)

Due to how our infrastructure works, your Repl will need to go to sleep at least once daily. Without Always On, it will not wake up unless your Repl is a web server and you are using a pinger or sending a request to it. If you are using Always On, we will automatically detect the downtime and restart the Repl.

Official Documentation: https://docs.replit.com/power-ups/always-on

ok, thank you, but that is a tad annoying especially when databasing